VideoURL and other URL's are not inserting

Nov 27, 2007 at 12:10 PM
Edited Nov 27, 2007 at 1:21 PM
Hi
I run the application Successfully and i uploaded videos , videoname and size and other values were inserting , but the URL'S of video are not inserting the table. how can i insert these fields? i tried manuvally copy and past the URL's its working fine, but its not a process, please help me how can i get the URl's into my database?

Thanq
NmRao........
Nov 28, 2007 at 1:16 PM
NmRao,

I am on the VS 2008 Release. I upgraded the Linq, dbml, etc... to get it running. I am uploading the files but the URL's are not populating (same as nmrao). Does anyone know of a work-around?

Cheers,
Carlos

nmrao wrote:
Hi
I run the application Successfully and i uploaded videos , videoname and size and other values were inserting , but the URL'S of video are not inserting the table. how can i insert these fields? i tried manuvally copy and past the URL's its working fine, but its not a process, please help me how can i get the URl's into my database?

Thanq
NmRao........

Dec 1, 2007 at 12:32 AM
Same here.
Dec 1, 2007 at 12:38 AM
The status message for every uploaded video is: "Encoded video file was not found".
Dec 4, 2007 at 9:01 PM
Has this been fixed?
Dec 12, 2007 at 8:32 PM
Need help! "Encoded video file was not found" error. Any solution yet?
Dec 13, 2007 at 4:47 PM
Hello! The "Encoded video file was not found" error has been fixed? Please, Help!
Dec 19, 2007 at 9:11 PM
Edited Dec 19, 2007 at 9:18 PM
It seems there are two problems in this thread:

1) The videos upload to Silverlight Streaming, but the Urls are not recorded after the upload.
Can you all check the StatusMessage and StatusId in the Videos table? Let me know what they say.

2) "Encoded video file was not found" error in the StatusMessage of the Videos table
This error message is usually an indication that Expression Encoder is not installed. Have you installed Expression Encoder?
http://www.microsoft.com/expression/products/overview.aspx?key=encoder

Dec 20, 2007 at 1:50 PM
Thank you for replying, mmoser!

1. I opened an account at Microsoft Silverlight Streaming. The StatusID is 7 and the StatusMessage is "Encoded video file was not found" in the Database. The VideoURL and the PreviewURL are null.

Info:

<add key="AccountId" value="-----"/>
<add key="AccountKey" value="-----"/>
<add key="DefaultPassword" value="-----"/>
<add key="NewUsersCanUpload" value="true" />
<add key="HideAdministratorAccount" value="false"/>
<add key="MediaEncoderPath" value ="C:\Program Files\Microsoft Expression\Encoder 1.0\"/>

2. I downloaded the Trial Version of Microsoft Expression Encoder a few weeks ago. The Trial hasn't expired yet.

- Do you think there are permissions problems? When the video is uploading, it use the Encoder.exe in the file system.
- Does it matter that I am behing a corporate firewall?
- I'm uploading a .mov (Quicktime Movie File) of 15mb. The settings in the web.config file are:

<httpRuntime executionTimeout="1800" maxRequestLength="2097151" />

- Database is working perfectly, both in the Data and Web projects. I'm using SQL Server 2005 Standard Edition, with Windows and SA Authentication.

Thank you for your help.


mmoser wrote:
It seems there are two problems in this thread:

1) The videos upload to Silverlight Streaming, but the Urls are not recorded after the upload.
Can you all check the StatusMessage and StatusId in the Videos table? Let me know what they say.

2) "Encoded video file was not found" error in the StatusMessage of the Videos table
This error message is usually an indication that Expression Encoder is not installed. Have you installed Expression Encoder?
http://www.microsoft.com/expression/products/overview.aspx?key=encoder



Dec 20, 2007 at 6:36 PM
I have created a document that outlines the upload process and highlights key areas of concern. In your case, you will see that the error you receive can actually mask a more specific error that occurs earlier in the code. Place a break point in the VideoEncoderService.Encode method to see why the Encoder is actually failing. This document will also help you follow the upload process through its different steps and check for expected output at each point in the process.

Please report back the exception thrown and caught in the VideoEncoderService.Encode method.

http://cid-0c6f123e4b6843d1.skydrive.live.com/self.aspx/Video.Show.Public/Upload%20Process.docx

Thanks,
--mm
Dec 20, 2007 at 6:48 PM
Thanks. I'm going to go over it. I will let you. Thanks again.


mmoser wrote:
I have created a document that outlines the upload process and highlights key areas of concern. In your case, you will see that the error you receive can actually mask a more specific error that occurs earlier in the code. Place a break point in the VideoEncoderService.Encode method to see why the Encoder is actually failing. This document will also help you follow the upload process through its different steps and check for expected output at each point in the process.

Please report back the exception thrown and caught in the VideoEncoderService.Encode method.

http://cid-0c6f123e4b6843d1.skydrive.live.com/self.aspx/Video.Show.Public/Upload%20Process.docx

Thanks,
--mm

Dec 20, 2007 at 11:55 PM
mmoser:

It now works. It seems when I opened the Silverlight Streaming Account, it was not activated immediately. Do you know how long does Microsoft takes to activate the account? Anyway, I'm very grateful for your help. Keep up the good job.


tommyfoo wrote:
Thanks. I'm going to go over it. I will let you. Thanks again.


mmoser wrote:
I have created a document that outlines the upload process and highlights key areas of concern. In your case, you will see that the error you receive can actually mask a more specific error that occurs earlier in the code. Place a break point in the VideoEncoderService.Encode method to see why the Encoder is actually failing. This document will also help you follow the upload process through its different steps and check for expected output at each point in the process.

Please report back the exception thrown and caught in the VideoEncoderService.Encode method.

http://cid-0c6f123e4b6843d1.skydrive.live.com/self.aspx/Video.Show.Public/Upload%20Process.docx

Thanks,
--mm